Vamos a ver una solución para un mensaje de error que me lanzo la consola de uno de mis clientes que utilizan WordPress, puntualmente el plugin de Mapas, que decía algo como: “Google Maps API key is required”

Esto se debe a que Google desde ha cambiado su política de uso de API de Google Maps, finalizando el tiempo de gracia el 12 de octubre de 2016, después de esta fecha para seguir usando Google Maps en tu sitio web de forma gratuita debemos hacer algunos pasos adicionales. Lo recomendable es usar Google Chrome y abrir tu cuenta de gmail.

1- Solicitar clave API

Hay que ingresar a la siguiente dirección: https://console.developers.google.com/apis

Vamos a Crear proyecto

2- Y le asigamos un nombre, aceptamos los terminos de uso y le damos clic a CREAR.

3- Ahora clic en Google Maps JavaScript API.

4- La habilitamos, clic en HABILITAR

5- Tenemos que crear unas credenciales, tocamos Crear credenciales, acá tenemos una pregunta inicial que es ¿Que API estas utilizando? y le decimos que usaremos Google Maps JavaScript API.

La segunda pregunta le hacemos clic en ¿Que credenciales necesito? para que se generen.

6- Ya tenemos la clave así que clic en Listo.

7- Esa clave la introducimos en la aplicación, como en mi caso era un wordpress, como ven en la primer captura donde dice Browser API Key, la pegamos ahí y guardamos los cambios para que Google Maps este funcional de nuevo.

Dejar respuesta

Please enter your comment!
Please enter your name here