Si estas queriendo actualizar metasploit, en este caso sobre Kali Linux, y al lanzar el clásico comando para hacer el update, msfupdate, y te da el mensaje que ya no se puede, hay solución y te muestro como solucionarlo.

msfupdate is no longer supported when Metasploit is part of the operating system. Please use ‘apt update; apt install metasploit-framework’

A partir de las nuevas versiones de Kali, ahora metasploit esta integrado al sistema operativo, por lo que hay que actualizar el sistema directamente con:

# apt update && apt-upgrade -y

Y si falta algún que otro paquete tal vez tengas que actualizar librerías haciendo un

# apt dist-upgrade

También puede pasar que necesites reinstalar la aplicación

# apt install metasploit-framework

Deja un comentario